Pages

Thursday, December 1, 2011

AIX File system

New File System Creation
mklv -y ibmdb2inst1 -t jfs2 rootvg 6
crfs -v jfs2 -d ibmdb2inst1 -m /db2/db2inst1 -A yes -a logname=hd8
mount /db2/db2inst1
df -gt

Increase FS size
chfs -a size=+10G /usr

SCP for file transfer from putty
scp db2jcc.jar root@172.17.13.136:/usr/maximo/7.2/lib

RAM Size
bootinfo -r

Groups and Users
mkgroup id=999 db2iadm1
 mkuser id=1001 pgrp=db2iadm1 groups=db2iadm1,staff,idsldap home=/home/db2inst1 db2inst1
chuser expires=0 maximo
chown -R wasadmin:wasadmin /usr/maximo/7.2/lib

Find text in any file 
find / -name "*" | xargs grep <findtext>

Gzip
gzip cheap.suit You'll end up with a compressed file named cheap.suit.gz, and cheap.suit will be deleted.

Find Running Process
ps -eo pid,args | grep java
kill -9 pid

Convert from DOS2UNIX
perl -p -e'tr/15//d' *
or use
for file in `ls -1` ; do dos2unix $file ; done

AIX volume Groups
lsvg --> List all volume groups
lsvg -l groupName --> Shows details of the volume group.

No comments:

Post a Comment